Mobile View Doesn’t Work on SharePoint ( WSS 3.0) List

I recently ran into a situation where I couldn’t get the ‘Mobile View’ in WSS 3.0 to work on a list that I had created. I went into the view of the list and selected the Mobile checkboxes (‘Make this a mobile view ‘ and ‘Make this the default mobile view‘), but it still was not showing up on my SharePoint site’s mobile homepage. My first thought was “What makes this list different than the other lists that have mobile views that are working?”

The answer was easy: I had created the list by selecting Custom List in Datasheet View from the ‘Create’ page. There are no mobile view choices for datasheet views, so I had created a new ‘standard’ view for the list. Even though I could check the ‘ Make this a mobile view ‘ checkbox, it was not showing up on the mobile homepage.

I basically had to recreate the list using the Custom List option, instead of Custom List in Datasheet View option. This is likely a bug; I haven’t been able to come up with a reasonable explanation as to why it would act this way (and the fact that the Mobile options showed up reinforce my bug theory).

3 thoughts on “Mobile View Doesn’t Work on SharePoint ( WSS 3.0) List”

  1. I can confirm that this behaviour is also happening on our systems as well. Driving me crazy and I’m not happy about having to recreate my lists and port the data over.

  2. I can confirm that this behaviour is also happening on our systems as well. Driving me crazy and I’m not happy about having to recreate my lists and port the data over.

Leave a Reply